View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
I was actually getting the same issue when trying to compile, but I seem to have resolved it by using the SET PROCEDURE statement and not specifying the class file, e.g.
 

SET PROCEDURE TO fwfulltext8.fxp additive

oFullText = NEWOBJECT('classFullText') 

 
Don't know if that'll help, but worth a try!
 
Sent by FoxWeb Support on 06/22/2006 02:51:56 PM:
We are not able to reproduce the problem.  I assume you are using VFP 8, right?  Does the error prevent you from using the object?  Do you get the same error when you run the ftexample form?

FoxWeb Support Team
support@foxweb.com email

Sent by Judith Barer on 06/20/2006 07:26:03 AM:
I tried the code below and I still get the same error.
Sent by FoxWeb Support on 06/19/2006 07:10:38 PM:
Hi Judith,
 
There are a couple of minor problems with your code:
  1. You don't need to use the SET PROCEDURE TO statement if you are specifying the class file in the NEWOBJECT  function.
  2. The class name you specified in the NEWOBJECT function is incorrect.  The correct class name is 'classFullText' -- not 'FullText' (yes, I know that the documentation is incorrect).
 
Having said this, I still don't see why you would get the error you quoted.  Please try the following code:
 

oFullText = NEWOBJECT('classFullText', 'fwFullText8.fxp')

RETURN

 
Do you get the same error?

FoxWeb Support Team
support@foxweb.com email

Sent by Judith Barer on 06/19/2006 10:21:19 AM:
I am trying to integrate foxweb into my vfp 8.0 app. In my main procedure I issue the following commands
 SET PROCEDURE TO fwfulltext8.fxp additive
 oFullText = NEWOBJECT('FullText', 'fwFullText8.fxp')
 
 RELEASE PROCEDURE fwfulltext8.fxp
I get the following error when compiling -
Program c:\foxweb\foxwebfulltext\fwfulltext8.fxp has the following errors:
    Unknown AKEYWORDS - Undefined
Can anybody help me with this.
Thanks
Judith