View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   

When I turned on Internet Information Services | Web Management Tools | IIS Management Scripts and Tools I get:


Input Error: Can not find script file “C:\inetpub\adminscripts\adsutil.vbs”.


Looking in C:\inetpub I find no directory for adminscripts

 

When I further turned on Internet Information Services | Web Management Tools | IIS Management Console I now have a C:\inetpub\AdminScripts but I now get: Permission denied | ErrNumber: 70 (0x46) | Error Trying To Get the Object: W3SVC


Would it ease the pain to upgrade from Windows 7 Home Premium to Windows 7 Professional, Enterprise, or Ultimate thereby being able to take advantage of Windows XP Mode in Windows 7. My hardware does support hardware-assisted virtualization.


I assume that Windows XP Mode would allow running Apache instead of IIS 7.5.


Do you know of any traps, pitfalls or swindles associated with such an approach?

 
Sent by FoxWeb Support on 11/20/2010 02:08:34 PM:
It seems that adsutil.vbs is not installed on your computer. You can install it from Programs and Features -> Turn Windows features on or off. It's under Internet Information Services/Web Management Tools/IIS Management Scripts and Tools.
FoxWeb Support Team
support@foxweb.com email
Sent by George Gambill on 11/19/2010 07:06:40 AM:
in the command prompt I tried:cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1and got the following:Input Error: Can not find script file “C:\inetpub\adminscripts\adsutil.vbs”.I am using Windows 7 Home Premium
 
Sent by FoxWeb Support on 09/28/2010 08:06:20 PM:
Officially FoxWeb is not supported 64-bit versions of Windows, because of the problems associated with configuring and maintaining a 64-bit IIS system, running with 32-bit ISAPI extensions and filters. Advanced users should be able to (and are) running with this configuration, but we just can't support it.

Specifically, we have observed the following problems:
  • IIS can be run in 64-bit mode, or 32-bit mode, but only one mode can be active. If a 32-bit ISAPI extension or filter is encountered by a version of IIS configured in 64-bit mode, or vice versa, IIS fails with generic "HTTP 500 - Internal server error" error messages.
  • By default, IIS on 64-bit systems is configured to run 64-bit ISAPI modules. The mode can be switched from the command line, but in a few cases we have seen this setting reverted by windows updates. To configure IIS for 32-bit applications run the following from the command line, while in "Run as Administrator" mode: cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
  • In most implementations once IIS is configured to run 32-bit ISAPI modules, it starts returning a Service Unavailable error. The cause of this error is that by default IIS is configured to run the 64-bit ASP.NET ISAPI filter, which is no longer compatible with IIS now that it is in 32-bit mode. Some servers may be configured with additional 64-bit ISAPI filters, which would also be incompatible with 32-bit mode. The solution to this problem is to remove all 64-bit ISAPI filters from the IIS configuration. In the case of the APS.NET filter, you can replace it with the 32-bit version, but it's possible that other required filters do not have a 32-bit counterpart. Note that typically ISAPI filters are set at the server-wide level, rather than being web-site specific.
  • If any 64-bit ISAPI filters are subsequently installed (either manually, or by Windows Update and other application setup programs), they will break IIS (see Service Unavailable error above).
  • If ASP.NET is enabled on the server, the ASP.NET ISAPI extensions must also be replaced with their 32-bit counterparts in the Application Extension Mapping page of the IIS Services Manager to repair the ASP.NET configuration. Any other 64-bit extensions must also be replaced or disabled.
 
FoxWeb Support Team
support@foxweb.com email
Sent by irace_z28 on 09/28/2010 10:09:26 AM:
I recently downloaded Foxweb 4.3 and having trouble with the setup.
My computer is configured with Windows 7 Professional (64-bit) with VFP 9.0 installed.
 
Before installing Foxweb 4.3, IIS 7.5 was installed the following features:
  • IIS 6 Scripting Tools
  • IIS 6 WMI Compatibility
  • IIS Metabase and IIS 6 configuration compatibility
  • IIS Management Console
  • CGI
  • ISAPI Extensions
  • Default Document
  • Static Content

Path to my web tree (with fwx scripts) is c:\inetpub\wwwroot\.
When configuring Foxweb Control Center, from the Virtual Servers tab, the Default program root is c:\inetpub\wwwroot.  
 
When I attempt to open any fwx script from a browser, I get an HTTP 500 error.
 
Please help.
 
Thanks