View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
Ok - I'll use foxweb.dll only (not foxweb.exe)
 
On the problematic server, here are some clues:
 
1) I am able to serve static (html) pages using IIS
2) attempting to call http://HOSTNAME/cgi/foxweb.dll/show_channels returns the "Page Load Error" (Connection Interrupted) error in Firefox
3) attemping to call a test Foxpro script returns the same error - and I noticed that a test.fxp file never got generated from the test.prg script
4) nothing in the error log
5) the fwstart.log indicates that foxweb is attempting to restart all 6 channels every 30 seconds (all day long) - the fwstart.log contains nothing else
 
 
05/11/2009 15:48:04 Restarting Channel 1
05/11/2009 15:48:04 Restarting Channel 2
05/11/2009 15:48:05 Restarting Channel 3
05/11/2009 15:48:06 Restarting Channel 4
05/11/2009 15:48:06 Restarting Channel 5
05/11/2009 15:48:07 Restarting Channel 6
05/11/2009 15:48:34 Restarting Channel 1
05/11/2009 15:48:34 Restarting Channel 2
05/11/2009 15:48:35 Restarting Channel 3
05/11/2009 15:48:36 Restarting Channel 4
05/11/2009 15:48:36 Restarting Channel 5
05/11/2009 15:48:37 Restarting Channel 6

It's a brand new foxweb installation - but maybe something is corrupted somewhere? 

Note that this server is also running Coldfusion and is able to serve coldfusion scripts just fine.

Randy

Sent by FoxWeb Support on 05/06/2009 11:18:05 AM:
Foxweb.exe should not be used with IIS, but the foxweb.dll issue may indicate a serious problem on one server. Do other scripts run OK on that server?
 
Regarding the channel restarts, please send us a full copy of fwstart.log via email.
FoxWeb Support Team
support@foxweb.com email
Sent by Randy Byers on 05/06/2009 06:59:31 AM:
A followup to this issue.  On server #2, the fwstart.log shows that foxweb keeps trying to restart channels.  At the moment, there are app. 20 vfp9.exe processes running when I have the system configured for only 6 channels.  I was also seeing a bunch of Windows error reporting notifications about IIS worker threads dieing. 
 
Randy
Sent by Randy Byers on 05/06/2009 06:43:56 AM:
Hello,
 
I have just installed Foxweb 4.3 on two Windows 2003 SP2 servers
running IIS.
 
Server #1
- /cgi/foxweb.dll/show_channels -> works OK
- /cgi/foxweb.exe/show_channels -> returns a blank page - view page source shows nothing at all (no HTML content)
 
Server #2
- /cgi/foxweb.exe/show_channels -> returns a blank page - view page source shows nothing at all (no HTML content)
- /cgi/foxweb.dll/show_channels -> returns a "Page Cannot be Displayed" error in IE and a "Page Load Error / Connection Interrupted" error in Firefox
 
Any ideas?

Randy