View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
I made a webpage whoare function properly in the production server. But in my computer with the development license the same page is presenting the error of alias not found.
 
The page  use an odbc connection to retrieve information and present the error:
 

There was an error during the interpretation of your request.

Error #:      13
Message:   Alias 'CSMSIPCRI' is not found.
Program:   g:\foxweb\fw\chum\repsonline\resultadocilat.fxp
Line #:   55
Line:   SELECT csMsipcri
 
But only in my computer, in the production server works very good. The code with problem is:
 
**Genera la conexión***************
STORE SQLCONNECT('MICROSIP_CRI', 'SYSDBA', 'masterkey') TO conex_vtas
If conex_vtas <= 0 %>
   <p><%response.write("No se puede conectar a MSIP CRI")%></p>
<%ELSE
**almacena la consulta en una variable 
TEXT TO lcSQL TEXTMERGE NOSHOW
SELECT cliente_id,nombre,estatus,fecha_hora_creacion
FROM clientes cicri
WHERE cicri.fecha_hora_creacion BETWEEN <<fechaini>> AND <<fechafin>> AND estatus='A'
ENDTEXT
**Ejecuta la consulta en la fuente de datos y almacena en cursor 
=SQLEXEC (conex_vtas,lcSQL,'csMsipcri') 
endif
SELECT csMsipcri
********************** 
 
In the line 55 I'm selecting the cursor csMsipcri and present the error of alias not found.
 
Is possible that something corrupt the installation of fowxeb? I'm using 3.5
 
In production server I dont have the problem. If I create a new program using cursors appear the same error all the time in my computer.
 
Please help me to find out what could happen? Do I have to reinstall Foxweb in my laptop?
 
Thank you in advance. 
Carlos