View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   


I confirm that fwserver.exe has been killed, there are only 3 FW processes running now instead of 4.
I'm also using FW Monitor which show that channel #1 is not used anymore.

I just make another test : I killed another FW process several times : it restarts immediately.
The following entries are present in fwstart.log :
09/26/2008 09:53:07 Restarting Channel 2 /online.fwx
09/26/2008 09:53:32 Restarting Channel 3 /planning.fwx
09/26/2008 09:53:51 Restarting Channel 3

You're right, DW20.exe is running, with as userid the same service account as foxweb.

As I said below, this is the second time that this problem happens.   The first time, the problem had been fixed by rebooting the server.
This time, I didn't reboot it.


Sent by FoxWeb Support on 09/25/2008 12:35:03 PM:
Is it possible that the VFP, or fwserver.exe process for channel 1 is still resident? I know you said you killed it, but could there be a mistake? Normally, if you kill a channel process, FoxWeb automatically restarts it (as long as the Restart Channels option is enabled).
Based on the information in the event log, it's possible that Windows Error Reporting was locking the channel process, preventing FoxWeb from killing it. Did you notice any instances of dw15.exe, or dw20.exe in the Processes tab of the Windows Task Manager? If yes, we can provide some guidance on how to avoid this problem in the future.
Also, did you have a chance to reboot your server since the problem happened?

FoxWeb Support Team
support@foxweb.com email
Sent by Joël on 09/25/2008 10:02:41 AM:
Hello,

I'm using FW v4.3 with 2 virtual servers. 
I've migrated from Windows 2000 to a new server with Windows 2003 R2 with last service pack a few weeks ago.
FW running as a service with a service user from Active Directory

I use FW for years now without problem, but I don't understand what happens now.

For the second time,  in see in "foxweb channel status" that one of the 4 defined channels stays definitely with the status "not responding"

What I can see in the different logs for this 2nd time :

- Foxweb error log : "syntax error" in fw_exit.fxp on channel 1 at 17:36  (channel 1 is the one which is not responding)
This error has been fixed in the mean time, the other 3 channel works perfectly

- Windows Application log : error at 17:36

Description : Type de l'événement : Erreur
Source de l'événement : Microsoft Visual FoxPro 9
Catégorie de l'événement : Aucun
ID de l'événement : 1000
Date :  25/09/2008
Heure :  17:36:05
Utilisateur : N/A
Ordinateur : HANSOLO
Description : La description pour l'ID d'événement ( 1000 ) dans la source (Microsoft Visual FoxPro 9) est introuvable. L'ordinateur local n'a peut-être pas les informations de Registre ou les librairies requises pour afficher les messages émanant d'un ordinateur distant. Vous pourrez peut-être utiliser l'option /AUXSOURCE= pour récupérer cette description. Reportez-vous aux rubriques Aide et support pour plus de détails. Les informations suivantes font partie de l'événement : fwserver.exe; 4.3.0.0; 47139f24; unknown; 0.0.0.0; 00000000; 0; 00751200.

Translation (English is not my mother language) : description for event ID 1000 in the source (VFP 9) is not found.   The local computer has maybe not the register information or needed libraries to display messages coming from a remote computer.   Tou can maybe use the option /AUXSOURCE= to get this description back.    See help and support for more details.    The following informations are part of the event : fwserver.exe; 4.3.0.0; 47139f24; unknown; 0.0.0.0; 00000000; 0; 00751200.


Stopping and starting the service in the FoxWeb Control Center one hour later do NOT solve the problem, as channel 1 disapeared now from the Foxweb Channel Status.

4 "fwserver.exe" processes are still present in the processes list of Task Manager, but the one with the lowest process ID has abnormaly high processor time and memory usage.

Next step : I've killed this process.    The remaining 2,3 and 4 channels seem to work perfectly.

Next step : Stopping and starting the service in the FoxWeb Control Center.    Nothing changed, channels 2, 3 and 4 are waiting or busy.
Channel 1 didn't come back, and only 3 fwserver processes are running (together with one fwstart)


Today's entries in fwstart.log are the following :
09/25/2008 18:50:29 Closing FoxWeb
09/25/2008 18:50:33 Starting FoxWeb
09/25/2008 18:56:38 Closing FoxWeb
09/25/2008 18:56:41 Starting FoxWeb

I did find another error previously :
09/15/2008 14:10:47 Insufficient rights to open FoxWeb registry key! Change user rights of service user.

I added some rights to the foxweb service user in the registry, and the error didn't come back.


Any help should be welcome

Thanks in advance