View Complete Thread | FoxWeb Forum Home
Date:    Msg ID:   
From:    Thread:   
Hello Carlos,
I use the program Freebyte to create Zip backup using Foxweb 4.3.  (
I have installed it in a directory called "freebyte" 
No problem at all
filelink=allt(sys(3))+""      &&(in order to keep the file name)
processx='c:\freebyte\fbzip.exe -a -p -r "'+filename+'"  "c:\dirwithfilestozip\*.dbf"'
run  &processx
processx='c:\freebyte\fbzip.exe -a -p -r "'+filename+'"  "c:\dirwithfilestozip\*.fpt"'
run  &processx
<a href="<%=filelink%>">Get the zip file</a> 
Sent by Carlos Fuertes on 04/27/2008 02:53:59 PM:

I have been using this code in a foxweb script for years with the Foxweb 2.6 release and it has worked fine, but now, with the last version 4.0 running in Windows Vista, it doesn't work anymore:

LOCAL lcAvisoPRG, lcAvisoZIP, lcAvisoEXE, lcDirectorio

lcDirectorio = "C:\MANTEMAIL\200302208ZARA"

lcAvisoZIP = lcDirectorio+"\Aviso.ZIP"

lcAvisoEXE = lcDirectorio+"\Aviso.EXE"

RUN/N2 C:\wzzip.exe &lcAvisoZIP &lcAvisoEXE

I'm using Winzip 9.0 with the Winzip Comand Line Add-on (WZZIP.EXE). I have tried also with Winzip 11.0 with the same result.
My environment is Foxweb 4.0, Windows Vista Business, Visual Foxpro 9 SP2.

When I run the code in the Visual Foxpro 9.0 SP2 environment, it works fine and the file is created. When I put the code in a prg file and I call the prg file from a Foxweb script, it doesn't work at all.

¿Any ideas?

Thankyou very much in advance