View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
I had a peculiar problem, with a peculiar solution.  I'm sharing it here in case anyone else runs into this.

I installed FoxWeb 4.0 and VFP 9.0 SP1 on a brand new server.  (BTW, this is not the machine we worked on last week, Pandelis...completely unrelated.)


FoxWeb runs just fine as an application, when I am logged in.  (I have admin rights.)

When I ran it as a service, logged in as foxweb_service (the account FoxWeb has been running as for years on our servers, with permissions limited appropriately), I got back in the browser the "No Channels Active" FoxWeb message.  (Notably, my browser (FireFox) offered to save the file, and would not display it.  I suspect the MIME type was bad, but I didn't chase that issue down.)

No entries in the FoxWeb error log.
No entries in the Windows event log.
Channels shown restarting (but not being killed) in fw_start.log.

I changed the service to log in as me, and things worked fine.  I changed it back to foxpro_service, and it broke.  At this point, I was pretty certain it was a permissions problem.

I added explicit permissions for foxweb_service (actually, for a group to which that this account belongs) to the VFP, FoxPro, CGI, and web root directories.  No improvement.

I then logged out of the server, logged in to the console as foxweb_service, and started FoxWeb as an application (I think...might have been as a service, but I don't think so.)  This time, a dialog popped up that read:

    "The resource file is not valid.  Overwrite it with a new empty one?  Yes/No"
   
I selected "Yes" and everything went fine.

I shut down FoxWeb, logged out, logged in as myself, and started FoxWeb as a service, running as foxweb_service, and everything went smoothly.


At this point, I'm a happy camper.  I'll follow up if anything comes up.  Hope this helps if anyone else runs into this.


-dave

--
David Hempy
Internet Database Administrator
Kentucky Educational Television
(859)258-7164 - (800)333-9764