View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
Thanks, your answer fixed the issue.  I had installed FoxWeb and it created the script mappings, but due to some other issues I uninstalled it.  During the uninstall, it did not remove the script mappings so I manually deleted them.  When I re-installed FoxWeb, it didn't recreate the mappings, so I manually created them and had the "Check that File Exists" box checked.  Unchecking this box and Unchecking the "Use Web Server's Directory Mappings" and the program root is functional now.
Thanks for the quick and easy fix, you were dead on right.
Don
Sent by FoxWeb Support on 03/06/2007 03:56:05 PM:
Did you create the .fwx script map yourself, or are you using the one created by the FoxWeb setup program?  The problem seems to be that the Check that File Exists option is enabled in the script map configuration.  This setting must not be enabled, unless you are using the Use Web Server's Directory Mappings option.
Please refer to the Configuring your Web Server topic in the FoxWeb documentation for details on how to correctly set up a script map for IIS.  While you are at it, you should make sure that the Script Engine setting is enabled. 
FoxWeb Support Team
support@foxweb.com email
Sent by Don Olsen on 03/06/2007 09:35:43 AM:
Hi, I am running the following configuration:
  Windows 2003 Standard
  IIS 6
  FoxWeb 3.5.1
I am only able to run scripts when the "Use Web Server's Directory Mappings" is checked (.fwx files are contained within the webserver directory structure).  The virtual directory (Program Root) option is not working.  Default Program Root is set to d:\inetpub\wwwroot\forms\foxweb\
With "Use Web Server's Directory Mappings" checked I can execute the form correctly at:
With "Use Web Server's Directory Mappings" unchecked the following URL returns a 404 page not found error
Any assistance would be helpful, as I'd rather use the Program Root option.
Don Olsen