View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   

When FoxWeb is running as a service, it runs under the context of the user that is specified in the service properties.  By default, FoxWeb will run under the System account, which has all rights on the local server, but no rights to access remote resources.  You can change the service user, by following the instructions in the thread you quoted.

If the Netware client requires manual login after you log into Windows (as opposed to automatically using your Windows userid and password), or if it replaces the Windows login procedure, then you will not be able to connect to your Netware resource, unless you figure out how to log in programmatically, using the Netware API.

FoxWeb Support Team
support@foxweb.com email
Sent by on 02/14/2007 11:18:28 AM:
 I experienced exactly the same behavior described on the emails below. I also have the same hardware/software configuration (except Foxweb, which is now version 3.51). I agree with you that the problem has to be in Netware.
In order to connect to Netware File Servers from Windows PCs, we are still using the Microsoft Client **Service** for Netware, so I guess it should be up and running as a service too (without having to log-in a user).
Have you identified the problem with this configuration? I prefer to have a service and not a user logged-in in order to start the FoxWeb program...
 Regards.
AS
*********************
The primary difference between running FoxWeb as a service and as a desktop application is the user under which it runs.  Are you sure you setup up the service user correctly?  After you did so, did you restart the FoxWeb service?
Another possibility is that Windows is configured so that as soon as you log into the system it executes a program that gives you access to your Netware server.  Obviously if you are running as a service, this program would never be executed.  I am not familiar with Netware connectivity, so I don't know whether this is the case.

FoxWeb Support Team
support@foxweb.com email

Sent by Lew En Lai on 05/27/2004 04:05:01 AM:
I have disabled Foxweb running as a service. Tested the script via the web and it works. What is the difference running it in the service applet or activating foxweb directly? It is not running as a service now and the UNC path is working perfectly. Is it alright to continue as it is now? Please advise.
Thanks
Sent by FoxWeb Support on 05/26/2004 02:54:54 PM:
Please try the following:
  1. Stop the FoxWeb service.
  2. Configure FoxWeb to not run as a service, by disabling the Run As a Service option in the FoxWeb Control Center.
  3. Login into Windows as the user you specified in the services applet for the FoxWeb service.
  4. Try running your script again.

Does this work?  If not, try the exact same code in an interactive VFP session.  Please let us know what you find out.

FoxWeb Support Team
support@foxweb.com email

Sent by Lew En Lai on 05/26/2004 06:14:27 AM:
I too am encountering the same problem and I tried the method you mentioned here but it still didn't work.
I have set up foxweb 2.6 with Windows 2003. My remote database is residing in my Netware 6.5 server. My Windows 2003 server is logged into the netware server via a netware client and mapped to the netware server.
I have specified the Userid and password of the Windows 2003 user which have access to my netware servers in the properties of the service applet. The foxweb is set to run as a service.
I managed to open the file interactively in VFP via the UNC path but it was unable to open the remote file via executing the foxweb script on the web returning the error that file does not exist.
In the programme it is executed as follows
vPath=alltrim(Fieldpath)+"myfile"
Use &vPath
(fieldpath is the UNC path stored in DBF and "myfile" is the file name)
Please advise.
Thanks
Sent by FoxWeb Support on 02/16/2004 11:58:00 PM:
You will need to open the Services applet in the Administrative Tools of the Windows Control Center.  Locate the FoxWeb service and open its properties.  In the Log On tab select "This account" and specify a userid and password for a user that has access to the remote resource.
In order to refer to the remote file in your script you must use UNC notation (\\ServerName\Share\Path\FileName).  To verify that everything is correct, log into the server as the FoxWeb service user and try to open the file interactively in VFP, using the same UNC path as what you used in your script.

FoxWeb Support Team
support@foxweb.com email

Sent by Fernando Medan on 02/13/2004 04:00:01 AM:
If you are running FoxWeb as a service running as an account that has access to remote resource (Win 2003 + FoxWeb 2.6).
When I tried to access via Foxweb, the error returned that the file does not exist.
Could you guide me through the steps on setting the service user and script.
Thanks