View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
Somehow, a setup program with two incorrect files made it onto our site.  One of the files was a version of fwconfig.exe compiled with VFP 9 instead of VFP 8.  The other was an older version of foxweb.dll, that did not contain a fix that would allow it to work with the following change from version 3.5:
 
HTTP headers are now separated with CRLF instead of just LF, so as to comply with RFC 822 and 2616.
 
Both problems have been corrected in version 3.5.1, which is now available on our site.
 
The licensing information should not have disappeared, unless you somehow uninstalled FoxWeb, before installing the latest version.  Note that an uninstall occurs automatically when you upgrade from version 3.0 (but not 3.1), because we had to break the setup package compatibility between 3.0 and 3.1.  Microsoft removed files from the VFP run-time library redistributable package to address the GDI security problem about a year ago, necessitating this change.

FoxWeb Support Team
support@foxweb.com email

Sent by James Williams on 09/26/2006 04:16:25 AM:
Just upgraded from 3.1, all want ok apart from when I tried to launch the foxweb control center. I got an cannot find libary error. I am using vfp7 in conjunction with foxweb. i had to install vfp9sp1 runtimes to get it to work.
 
I also had to re-enter my licence numbers, as they all disappeared.
 
You may want to tell people this before they download and try to upgrade.