View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
There's something that's preventing the FoxWeb Channel Controller from detecting the fact that channels have started properly, so it tries to restart them.  We have placed a new version of fwstart.exe and foxwebctrl.ocx on our site (http://www.foxweb.com/bin/fw35_patch.zip).  Please try replacing your current files with these and let us know if it helps.

FoxWeb Support Team
support@foxweb.com email

Sent by on 07/11/2006 12:38:20 AM:
>Does the problem happen when you run FoxWeb as a
>service, regular desktop application, or both?
 
Both.
 
>Also, please verify that all executables were replaced >properly when you upgraded to version 3.3.  What are
>the dates/version numbers of
 
>fwserver.exe, 
 
02 - 03 - 2006
 
>foxwebctrl.ocx
 
09 -10 - 2004
 
>and fwstart.exe?
 
24 - 05 - 2005
 
 
Bye
Paolo.
 
Sent by FoxWeb Support on 07/06/2006 08:07:45 AM:
Does the problem happen when you run FoxWeb as a service, regular desktop application, or both?
 
Also, please verify that all executables were replaced properly when you upgraded to version 3.3.  What are the dates/version numbers of fwserver.exe, foxwebctrl.ocx and fwstart.exe?

FoxWeb Support Team
support@foxweb.com email

Sent by on 07/03/2006 01:37:52 AM:
No, you can't reach the server over the net (I asked for your request to our sys admin...), but if you want I can try to send to you a virtual machine on wich the errors appears.
It's size in about 800 MB (Zipped), I can try to find a way to upload to you this file on a FTP site. (if you have...)
 
Paolo
 
Sent by FoxWeb Support on 06/29/2006 11:08:57 AM:
Is your server accessible over the Internet?  Can we connect via Remote Desktop?  If not, can we connect to it with a browser?  Please contact us directly via email if you don't want this information made available in this Forum.

FoxWeb Support Team
support@foxweb.com email

Sent by on 06/29/2006 04:01:00 AM:
We 've just upgraded our foxweb to 3.3 version.
 
Here is a piece of fwstart.log :
 
06/27/2006 10:04:07 Starting FoxWeb
06/27/2006 10:04:16 Restarting Channel 1
06/27/2006 10:04:17 Restarting Channel 3
06/27/2006 10:04:26 Restarting Channel 3
06/27/2006 10:04:27 Restarting Channel 1
06/27/2006 10:04:31 Restarting Channel 1
06/27/2006 10:04:31 Restarting Channel 2
06/27/2006 10:04:32 Restarting Channel 3
06/27/2006 10:04:35 Restarting Channel 1
06/27/2006 10:04:45 Restarting Channel 1
06/27/2006 10:04:47 Restarting Channel 3
06/27/2006 10:04:48 Restarting Channel 2
06/27/2006 10:04:50 Restarting Channel 1
06/27/2006 10:04:51 Restarting Channel 3
06/27/2006 10:04:52 Restarting Channel 2
06/27/2006 10:04:55 Restarting Channel 1
06/27/2006 10:04:55 Restarting Channel 2
06/27/2006 10:04:56 Restarting Channel 3
06/27/2006 10:05:00 Restarting Channel 1
06/27/2006 10:05:00 Restarting Channel 3
06/27/2006 10:05:03 Restarting Channel 1
06/27/2006 10:05:03 Restarting Channel 2
06/27/2006 10:05:04 Restarting Channel 3
06/27/2006 10:05:07 Restarting Channel 1
06/27/2006 10:05:11 Restarting Channel 1
06/27/2006 10:05:11 Restarting Channel 2
06/27/2006 10:05:12 Restarting Channel 3
06/27/2006 10:05:15 Restarting Channel 3
06/27/2006 10:05:16 Restarting Channel 1
06/27/2006 10:05:16 Restarting Channel 2
06/27/2006 10:05:32 Closing FoxWeb
 
Paolo.
Sent by FoxWeb Support on 06/28/2006 11:05:49 AM:
Which version of FoxWeb are you running?  There are some related issues, that were fixed in FoxWeb 3.3.
 
Also, did you check for any error messages in fwstart.log?

FoxWeb Support Team
support@foxweb.com email

Sent by on 06/28/2006 02:40:37 AM:
Good morning,
 
I use Foxweb version 3 on a server installed with Windows 2003 with IIS 6.0.
The problem is that foxweb continuously restarts its channel : I have already tried to run foxweb "not as a service" with "hide windows" disabled and foxweb doesn't visualize any error message, simply open&kill&close&reopen the channel windows.
 
I have observed this kind of behavior on two different server : the first one is a production server on which foxweb was installed and run successfully until a Microsoft Update was installed, after that foxweb started having problems; the second server is a virtual machine created with Win2003, Sql2005, IIS 6 and Foxweb.
 
The workaround to this problem, (it can't be considered a solution!!) is to disable the option "auto restart channel" and magically foxweb starts to run in the right way, every channel starts and no one is restarted (this happen obviously also if a channel is killed for an error o time out reason...).
 
Thanks for your help.
 
Paolo.