View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
In order to switch from http to https, you need to include a fully qualified URL in your link, meaning a URL that starts with http:// (or in this case https://).  Fully qualified URLs are not the same thing as what the FoxWeb Control Center refers to by "Full paths in URLs".  The latter kind of URL includes the full file system path to your script in the URL (for example http://www.server.com/c:/program%20files/foxweb/scripts/myscript is a request for a script in c:/Program Files/FoxWeb/scripts folder).  The problem with these URLs is that they can call a prg or fwx file anywhere on your server, which makes them very insecure and this is why they are disabled by default.  The only reason there's even an option to allow them is because some realy old applications rely on them.
 
I really don't understand why you would be getting the error you described.  What URL did you use? 

FoxWeb Support Team
support@foxweb.com email

Sent by Joe Goldsmith on 04/27/2006 07:29:05 PM:
Back to my shopping cart project...I'm now on SSL with https. When a visitor performs some action that requires a full URL I want the link to call the script with https. I keep getting a FoxWeb error that full URLs cannot be used. In the control panel | configuration I check the Full path in URLs checkbox. Then I get the error that I can't use this unless I also uncheck Use Web server's directory mapping. So, I uncheck that then I get a FoxWeb Foundation error. I cannot leave Use Web server's directory mapping unchecked as it is now.
 
How can I incorporate an https://www.... without getting this error please?
 
Joe