View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
Sorry, I have just found another solution, in same time that you :
 
In the Fw_enter, I have added the line :
SET POINT TO '.'
 
Foxweb (using Vfp) always considers numbers with a point, even if the regional settings are set to ','.
 
But thank you for your help despite of everything. It help me to understand why it was working very well on certains servers and not on others.
 
Sent by FoxWeb Support on 03/23/2006 08:42:20 AM:
The regional settings are stored in the registry under hkey_users.  If you want to keep FoxWeb running as a service under the Local System account, you will have to find the registry entries for the settings you are trying to change and re-create them in the sub-key used by Local System.  This will require some research on your part.

FoxWeb Support Team
support@foxweb.com email

Sent by jipi on 03/22/2006 11:20:47 PM:
Thank you for responding so quickly.
I have created a new account and in fact, it works very fine.
 
But the problem is, that Foxweb is installed among our customers, so we can't make them do it. They are not data processing specialists.
 
Is there an easier solution.
 
Sent by FoxWeb Support on 03/22/2006 09:55:40 AM:
It seems that the regional and language options are user-specific.  When you run FoxWeb as a service, it runs with the user rights of the user specified in the Log On tab of the service properties (Control Panel\Administrative Options\Services).  If the FoxWeb Service is running as the Local System account, then you should change this to a different user that has enough rights to run FoxWeb.  At that point, you should log into Windows as that user and change the regional settings.

FoxWeb Support Team
support@foxweb.com email

Sent by jipi on 03/22/2006 08:48:40 AM:
 
Hi,
We display data coming from an Access database with numerics values.
 
We have configure ' . ' in the Regional option, and put the correct dlls in "windows\system32" directory.
 
If foxweb is running as service, the numeric values (with '.' in the database), is converted with ',' (comma) .
 
If foxweb run normaly (not as a service), the numeric values are correct (with a '.' when displaying).
 
If I run the same database request with VFP6 manually, It works very well.
 
Any Help please ?
I have tried with Foxweb 2.5, Foxweb 3 and the result is the same.
Please, it's very urgent.