View Complete Thread | FoxWeb Forum Home
Date:    Msg ID:   
From:    Thread:   

OK. After hours of messing around with FoxWeb and Abyss Web Server, I finally was able to get them to work together but in a rather unexpected way.

I'll explain the oddity at the end.

Here the Abyss Web Server configuration that works:

1) General -> Documents Path = 'C:\PROGRAM FILES\FOXWEB\PROGRAMS\'

2) You won't need any aliases just to get FoxWeb to work

3) Under Scripting Parameters -> ISAPI Parameters, add an extension:

ISAPI Filename Extensions = "dll" [I think this is the default anyway]

4) Under Scripting Parameters -> ISAPI Parameters, add an interpreter:

Interpreter = "C:\Program Files\FoxWeb\CGI\FoxWeb.exe"

Arguments =  <None>

Type = Standard

Use the associated ... = <checked>

Associated Extensions = fwx


BUT ...

Now here is the weird part:

Assuming you are running the whole show on your workstation, typing http://localhost/show_cgi.fwx should logically execute, but instead it gives an error message 'No script was specified in the URL'

It gets weirder:

Try this http://localhost/show_cgi.fwx /show_cgi.fwx

and viola!!! it works

I'm assuming this behavior is not unique to my computer because of all the different configurations I tried.  Here are some of the things I tried:

1) Used %1  or even %1 %2 in the arguments field under interpreters

2) Used FoxWeb.dll instead but the result was even worse.  With this configuration, I always get an error message "No program root has been configured for domain "" '.  Yes that's two quotation marks with nothing in between, indicating an empty string.  The error did get logged in FoxWeb control panel and I'm pasting the contents of the 'Memory Variables' tab:

SERVERVARIABLESLEN   Local     N     51.00                                              (             51.00000000)  initvars

POSTDATALEN          Local     N     0.00                                               (              0.00000000)  initvars

INPUTBUFFER          Local     C     ""  initvars

CONTENTTYPE          Local     L     .F.  initvars

I                    Local     L     .F.  initvars

CURLINE              Local     L     .F.  initvars

PREVPOS              Local     L     .F.  initvars

NEXTPOS              Local     L     .F.  initvars

TOTFIELDS            Local     L     .F.  initvars

BOUNDARY             Local     L     .F.  initvars

UPLOADEDFILENAME     Priv      C     ""  initvars

SERVERNAME           Local     C     ""  getprogramroot

PROGRAMROOT          Local     C     ""  getprogramroot

Obviously the program root is set correctly or I should get the same message using FoxWeb.exe also.

3) Tried arguments with the DLL interpreter also

4) Played around with Scripting Parameters -> Script Paths with no success.

So, the end result is that I have FoxWeb working with Abyss Web Server and that is all that matters.  I don't know whether it is FoxWeb or Aprelium Technologies that need to change something to get these two to work more harmoniously, but I will leave that to the pros to figure out.

Good day all,


Sent by SinclairZX81 on 01/25/2005 09:33:55 AM:
Has anyone sucessfully configured Abyss Web Server to work with Foxweb?  I have already refered to the help documentation about the scripts (CGI) but can't seem to get the foxweb configuration right.
The FoxWeb.exe is loaded in the cgi-bin (scripts) folder of Abyss, and I have loaded the CGI interpreter settings of Abyss as show in the parameters below:
CGI Parameters:
CGI Interpreters:
J:\Program Files\Abyss Web Server\cgi-bin\Foxweb.exe
Associated Extensions:
CGI Paths:
User CGI Environment Variables:
When I try to run a script, for example the sample,, the browser returns the message:
HTTP 404 Not Found.
When I attempt to further path out the request using:
I get the foxweb executable to respond, but it answers with the message:  Script "CONTACT.FWX" is invalid, or non-existent.
I know it has to be a configuration issue, but am not sure which way to turn, so any help you can give would be appreciated, as I would like to try this fine product.  Thanks in advance.