View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
The script mapping setup procedure on Windows 2003 Server is identical to the one on Windows 2000.  The only difference is how you access the master properties for all sites.  In Windows 2000 you click on the entry that has the server name (the one that contains the various web sites on your server).  In Windows Server 2003 there's a new item, titled 'Web Sites'.  Simply right click on that item to bring up its properties:
 
 
Everything else is identical to the Windows 2000 procedure.  You can view a how-to movie of the procedure, by clicking on the "View how2" icon next to the Script Mapping section of the Configuring Your Web Server topic.

FoxWeb Support Team
support@foxweb.com email

Sent by ying on 10/20/2004 12:25:39 PM:
hi
 
thanks for the reply.
i'm still puzzled by where to set up script mapping in windows 2003? do you have an example case for windows 2003? i would really like to see the setting in picture like you did for web service extension for foxweb.
 
thank you
 
ying
 
Sent by FoxWeb Support on 10/14/2004 05:52:00 PM:
You are right in that there's no master page for setting up the location of the home  directory.  Each web site will have its own home directory, so you have to go to the individual property pages of that site.
 
Correct me if I'm wrong, but the mention of the master page is in relation to the setup of script mapping for the .fwx extension.  The assumption is that you want this extension to be script-mapped for all your web sites, so you have to set it up in your master property pages.  The concept applies in all versions of Windows, but the terminology and how you get to these pages varies for Windows 2003 Server.  In this OS you don't right-click on your server entry, but rather on the Web Sites item that appears when you expand this entry.
 
As I mentioned in my previous message, you do not want to set up the home directory of your web site to point to the location of your scripts.  The home directory of your site should point to the location where you store your static HTML pages and images.  By default this is c:\inetpub\wwwroot.
 
Your script location should be specified in the FoxWeb Program Root setting in the Virtual Servers page of the FoxWeb Control Center.  Your web server does not need to know where your fwx scripts are located.  Instetad, all it needs to know is the location of the ISAPI extension (foxweb.dll).  This is done by either utilizing script mapping in conjunction with the .fwx extension, or by creating a virtual directory that points to the location where foxweb.dll resides.  Both techniques are described in detail in the Configuring your Web Server page of the FoxWeb documentation.

FoxWeb Support Team
support@foxweb.com email

Sent by ying on 10/13/2004 10:34:17 AM:
thank you for your reply. my problem is still about configure IIS. in the page you provide, there is no master page when you click on the server's property page. i think that's the case under windows 2000. in windows 2003, the only way i can get to the home directory page is when you click on a specific web site's property page. there is "local path" to specify where your foxweb scipts are(?); and a "starting point" to configure, just like the app mapping in windows 2000. can you tell me what should i put in local path? i tried both "c:\program files\foxweb\programs" (my foxweb scripts location) and "c:\inetpub\wwwroot\cgi_bin"(where foxweb.exe and foxweb.dll locate). neither works. i still got the same error like:

HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

any more suggestion?

 

thanks a lot!

 

ying

Sent by FoxWeb Support on 10/07/2004 12:36:44 PM:
You do not need to concern yourself about creating a virtual CGI directory, unless you want to utilize URLs that refer to foxweb.exe, or foxweb.dll.  The recommended solution is to use script-mapped URLs.
 
The local path in the home directory should be set to it's default value (c:\inetpub\wwwroot?).  This path should contain only static files -- not fwx scripts.  FoxWeb will find your scripts, based on the Program Root setting in the FoxWeb Control Center.
 
We have updated the Configuring Your Web Server page with Windows 2003 information.  Here are the basic steps:
 
Configure IIS, so that it passes requests for .fwx files to foxweb.dll.  This is described under Windows 2003/Script Mapping section of the Configuring Your Web Server page.  You will also need to enable foxweb.exe and foxweb.dll as application extensions.  This is is described in the Enabling FoxWeb to Run on Windows 2003 section.
 
Once you complete that above, try calling http://localhost/show_cgi.fwx.  Hopefully you will see a page that was generated by FoxWeb.  Even if you get an error page (such as "FoxWeb has not been started"), you are on the right track.  Once you get to this point, you can concentrate on getting the sample scripts to run.

FoxWeb Support Team
support@foxweb.com email

Sent by ying on 10/07/2004 09:05:20 AM:
hi,
the link talks only about windows 2000/98/95, not much about windows 2003, which is much different from 2000. there is no default cgi directory in 2003 and cgi access is disabled.
to my understanding, in the home directory tab, local path means where your foxweb scripts are; while starting point is where the script mapping starts. in my case, i tell the web server how to interpret .fwx files.
i think i can enable cgi access by allowing foxweb web service extension. but still i can't run a single foxweb scripts.
 
could anybody tell me more about this IIS 6.0 or windows 2003?
 
thanks a lot!!!
 
frustrated ying
Sent by FoxWeb Support on 10/06/2004 04:54:44 PM:
You still need to configure IIS for FoxWeb access.  You can find detailed instructions in the Configuring Your Web Server page of the FoxWeb documentation.
 
I'm not sure what the distinction is between 'home directory --> local path' and 'home directory --> starting point'.  Here are a few things that I see wrong with your configuration:
  • The root directory of your Web site should never point to the FoxWeb path, but rather should point to a location that contains static html files and images (e.g. c:\inetpub\wwwroot).
  • You either need to set up script mapping for the .fwx extension (recommended), or create and use a virtual directory that points to foxweb.dll.  Both solutions are described in the documentation page listed above.
  • It is never a good idea to enable 'Scripts and executables' access for the root directory of your Web server.  What you should do instead is enable such access only for virtual directories that actually contain CGI executables and ISAPI DLLs.

FoxWeb Support Team
support@foxweb.com email

Sent by ying on 10/06/2004 03:17:57 PM:
hi,
i just baught a new dell powerEdge700 server with windows 2003 server as OS, running IIS6.0 version. after IIS server running okay, i tried to set up foxweb 2.6 on it. since i don't know much about IIS, i tried the following:
 
  • create a site called foxweb by IIS manager-->computer name--> web sites--> foxweb; in its property page,
    • web site tab, ip 141.211.111.141, port 65525
    • home directory--> local path: c:\program files\foxweb,
    • home directory -->starting point-->c:\inetput\wwwroot\cgi_bin\foxweb.exe for .fwx files
    • home directory --> execute permissions: scripts and executables
  • allow foxweb service by IIS manager --> computer --> web service extensions;
  • configure foxweb configuration center

while the default web site on this server at http://evalexam.umich.edu/tq_psych.htm is doing fine, i can't get foxweb program running. i don't know what i missed or did anything wrong. pls help!!!

thank you!
 
ying