View Complete Thread | FoxWeb Forum Home
Date:    Msg ID:   
From:    Thread:   
the link talks only about windows 2000/98/95, not much about windows 2003, which is much different from 2000. there is no default cgi directory in 2003 and cgi access is disabled.
to my understanding, in the home directory tab, local path means where your foxweb scripts are; while starting point is where the script mapping starts. in my case, i tell the web server how to interpret .fwx files.
i think i can enable cgi access by allowing foxweb web service extension. but still i can't run a single foxweb scripts.
could anybody tell me more about this IIS 6.0 or windows 2003?
thanks a lot!!!
frustrated ying
Sent by FoxWeb Support on 10/06/2004 04:54:44 PM:
You still need to configure IIS for FoxWeb access.  You can find detailed instructions in the Configuring Your Web Server page of the FoxWeb documentation.
I'm not sure what the distinction is between 'home directory --> local path' and 'home directory --> starting point'.  Here are a few things that I see wrong with your configuration:
  • The root directory of your Web site should never point to the FoxWeb path, but rather should point to a location that contains static html files and images (e.g. c:\inetpub\wwwroot).
  • You either need to set up script mapping for the .fwx extension (recommended), or create and use a virtual directory that points to foxweb.dll.  Both solutions are described in the documentation page listed above.
  • It is never a good idea to enable 'Scripts and executables' access for the root directory of your Web server.  What you should do instead is enable such access only for virtual directories that actually contain CGI executables and ISAPI DLLs.

FoxWeb Support Team email

Sent by ying on 10/06/2004 03:17:57 PM:
i just baught a new dell powerEdge700 server with windows 2003 server as OS, running IIS6.0 version. after IIS server running okay, i tried to set up foxweb 2.6 on it. since i don't know much about IIS, i tried the following:
  • create a site called foxweb by IIS manager-->computer name--> web sites--> foxweb; in its property page,
    • web site tab, ip, port 65525
    • home directory--> local path: c:\program files\foxweb,
    • home directory -->starting point-->c:\inetput\wwwroot\cgi_bin\foxweb.exe for .fwx files
    • home directory --> execute permissions: scripts and executables
  • allow foxweb service by IIS manager --> computer --> web service extensions;
  • configure foxweb configuration center

while the default web site on this server at is doing fine, i can't get foxweb program running. i don't know what i missed or did anything wrong. pls help!!!

thank you!