View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
Thanks for the information.
 
I was able to fix it by creating a new directory, copying the files from the old program root directory, renaming the old program root directory, renameing the new directory to the old program root directory's original name, and pointing FoxWeb to the new directory with the old name.  FoxWeb is able to see this one but still cannot see the old one.
 
The problem is fixed although I am still not sure why it cannot see the old one (even with its new name).
 
 
Sent by FoxWeb Support on 09/04/2003 05:05:19 PM:
There are two Program Root settings: the Default Program Root and the virtual host-specific Program Root.  unless you are running multiple virtual hosts, each with its own Program Root, you should only populate the Default Program Root and leave the virtual host-specific Program Root set to "default".
 
In any case, if the virtual host-specific Program Root is set, then it will be in effect, otherwise the Default Program Root will.  Make sure that the effective Program Root exists and that it is accessible by FoxWeb.
 
For details on configuring the software please refer to the FoxWeb Configuration topic in the FoxWeb documentation.

FoxWeb Support Team
support@foxweb.com email

Sent by Lynn Evans on 09/04/2003 07:56:57 AM:
Curious thing, the Program Root directory is still there but when I attempt to browse to it within the Program Root column in the FoxWeb Control Panel the directory listing does not include the currently specified Program Root Directory.  For some reason it does not see it from here.  Any sugestions as to why?
Sent by FoxWeb Support on 09/02/2003 07:24:09 PM:
FoxWeb attempts to set the current directory to the Program Root directory as defined in the FoxWeb Control Center before every hit.  Either this setting was changed to point to a non-existent location, or the directory was deleted accidentally.

FoxWeb Support Team
support@foxweb.com email

Sent by Lynn Evans on 09/02/2003 03:04:11 PM:
We have a FoxWeb app that a departed programmer wrote that was running just fine.
 
Suddenly it has started generating a FoxWeb Foundation Program Script error in the log.  Error 202 Invalid path or file name.  Line 135 SET DEFAULT TO (Request Program Root).
 
We must have changed something somewhere but I have looked and am unable to put my finger on it. 
 
Any suggestions?
 
Thanks,
 
Lynn Evans