View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
I'm getting an error condition from my site that does not occur on my local host. The current error reports:
 
***
There was an error during the interpretation of your request.

Error#          1705
Message:        File access is denied
Program:        C:\INETPUB\WWWROOT\WWW.DATATRACK.NET\INDEX.FXP
Line#           5
Line:           ERASE myprocs.fxp
***
 
This happens when I try to use the "ERASE my_procs.fxp" command although I got similar messages when trying to access procedures/functions from FWX pages with the following first 2 lines of code in my FWX:
 
<% SET PROCEDURE TO myprocs.prg
      DO proc1 WITH "myvar" %>
 
The errors then occured when line 1 or 2 was called.
 
An FTP 'delete' would remove the 'myprocs.prg' but not the 'myprocs.fxp' and the following line would display.
 
***
"550 myprocs.FXP: The process cannot access the file because it is being used by another process. "
***
 
It acts like the attribute of MYPROCS.FXP is set to read-only bu it can't be accessed either.
 
I had this situation before when MYPROCS was called MY_PROCS. It worked fine for a while and then the file locked.
 
I rewrote everything so that the procedure file became MYPROCS and it worked fine yesterday.
 
This morning, it locked up again.
 
Any ideas?
 
Gene