View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
So, just to be clear ...
 
You are saying that because Scripts is a virtual directory pointing to c:\inetpub\scripts, that the URL http://localhost/scripts/foxweb.exe/show_cgi will execute properly.
 
If that is what you are saying ... I have to defer to your expertise but my experience still remains that it did not work and I have no idea why.
 
Things work when I use the FWX mapping ... as http://localhost/show_cgi.fwx ... but not the explicit URL described above.
 
Well, I will assume you are right and will just have to continue to pay attention to things and it may work itself out in time.    Thanks for your responses on this thread.
 
 
Sent by FoxWeb Support on 12/06/2002 11:01:21 AM:
All installations of IIS and PWS have by default a virtual directory called scripts that points to c:\inetpub\scripts.  This directory is configured to allow scripts and executables.  The default root directory is c:\inetpub\wwwroot.  Even though scripts is not a subdirectory of wwwroot, the /scripts location works by virtue of the scripts virtual directory.

FoxWeb Support Team
support@foxweb.com email

Sent by Don Dascher on 12/06/2002 08:57:01 AM:
Well, here is what I experienced ...
 
The default CGI directory for IIS is c:\inetpub\scripts.
 
When Installing Foxweb, that is what I entered as the location of the CGI directory.  Foxweb.exe and Foxweb.dll are in that subdirectory; I checked. 
 
The default website for IIS is c:\inetpub\wwwroot.
 
Therefore, this URL is doomed ... http://localhost/scripts/foxweb.exe/show_cgi because the scripts subdirectory cannot be reached from localhost (localhost represents c:\inetpub\wwwroot) because the scripts subdirectory cannot be seen from c:\inetpub\wwwroot.
 
This could be solved be either ... 1. Creating a Scripts subdirectory off of the wwwroot subdirectory and defining it as the CGI subdirectory through IIS or 2. Setting the default website as c:\inetpub instead of c:\inetpub\wwwroot.
 
It can also be overcome through FWX mappings.
 
I only bring this to your attention because a complete novice to these ideas (which I am only a small step above), installing on XP with IIS  will never get past the TEST THE SERVER part of the instructions in the README file.
 
I have tried this twice on 2 different computers so I believe this to be accurate. 
 
It is always possible that I have overlooked something (I have done so many times before) but in this case I doubt it.