View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
On certain servers the CGI module of FoxWeb 2 will return this error every thousand requests or so.  Is this consistent with what you have observed, or do you get this message on a regular basis?
 
Even though you answered "No" to the question on whether you are using the CGI, or ISAPI module, I assume that you are using CGI, because you just upgraded from FoxWeb 1.2.  You can tell which module you are using by looking at the URL.  If the URL specifically referres to foxweb.exe, then you are using the CGI module.
 
As far as I know, the ISAPI module does not return this message under any circumstances.  In addition, ISAPI is a more efficient protocol, so you should see some performance improvements if your site serves a large number of requests.  The simplest way to get around the problem is to change all URLs so that they contain "foxweb.dll" instead of "foxweb.exe".
 
I understand that this may not be a viable solution for you.  If you are not able to change your scripts, then please let us know and we will try to find a different solution.
 

FoxWeb Support Team
support@foxweb.com email

Sent by Pedro Oropeza on 06/20/2002 07:25:15 AM:

HI:

a long time ago I had a problem with version 1.2 of foxweb sent the following message to me:

Error in cgi Back-End Program There was an error during execution of the back-end cgi program. The error is:

Error in CGI Back-End Program
There was an error during execution of the back-end CGI program. The error is: Could not load FWDLL.DLL
Make sure that the file is in the system directory and that the CGI user has read access to it (1114)
 
you recommended update to the new version of foxweb and I already did it, 2 days I work correctly but the third day send the following error:

Error CGI

La aplicación CGI especificada puede comportarse de norma anormal al no recibir un conjunto completo de cabeceras HTTP. La cabeceras retornadas son:
 
my system is:
  • Operating system  --  Windows NT
  • VFP version  --  6.0
  • Running as a system service?  --  Yes
  • Using run-time DLL?  --  No
  • Using CGI, or ISAPI module (FoxWeb 2 only)?  --  No
  • Web server software  --  IIS
  • The version of FoxWeb you are using  --  2.11

please help me

thanks