View Complete Thread | FoxWeb Forum Home
Date:    Msg ID:   
From:    Thread:   
I seem to have trouble with this.  In a Foxpro program I set the default directory to the foxpro install directory and then give it a

RUN /N vfp6.exe x:\programpath\foo\myprogram.prg

When I run this program from a Foxpro instance on the same machine as is running the CGI server, it works, "myprogram.prg" is open in a new foxpro instance.  When exactly the same program is called via foxweb, a new foxpro instance opens but it exits immediately.

I also tried doing this with a batch file.  From the foxpro program I called a batch file, and the batch file called foxpro with the "myprogram.prg" argument.  When this batch file was run from Windoze it worked as designed, called FP and ran the prg.  Likewise when the program which calls the batch file was run from a foxpro instance, it worked right.  When the same program was called from foxweb, it ran the batch file (I put a long 'type' command in so I could verify it ran) but FP didn't run the program.

Has anybody done something like this succesfully before?


The general idea is, I'm trying to work around the lack of any support for threads in foxpro.  This is the only approach I've been able to find.  If anybody else has come up with some approach to launching a foxpro process as a separate thread (other than the above) that would be helpful too.


Any help would be greatly appreciated, thanks.