View Complete Thread | FoxWeb Forum Home
Search:
Date:    Msg ID:   
From:    Thread:   
Subject:   
We have reproduced this problem and will be issuing a fix in the next week or so.

FoxWeb Support Team
support@foxweb.com

Sent by vadim on 12/06/2001 10:05:51 AM:
Now I can specify more exact situation:
cutted only that data, which has <"> symbol in its values

Auth form has line
<%=Auth.FormVars%>
generated output has

<input type="hidden" name="secSessionID" value="0JN0RHMYJ1">
<input type="hidden" name="bSave" value="Save">
<input type="hidden" name="code" value="ADVANCED">
<input type="hidden" name="note" value="mmmmmmmmmmmmmmmmmmmmmmmm
mmmmmmmmmmmmmmmmmmmmmmmm"mmm"mm
mmmmmmmmmmmmmmmmmmmmm
.... this text coming from textarea and can keep <">
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
xdcgsdfsdfmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm
aaaaaaaa">

first <"> symbol is end value inside of hidden tag created by Auth.FormVars()
you need to use server.htmlencode() in Auth.FormVars()

please fix it

**********************************************************
previous post was:

I meet this problem couple of time and on the different pages, but cannot reproduce it. My users also meet this problem.

how its happen:
my edit forms has textareas (memo field(s) but usually is not big)
1. login and view/edit data
2. user is iddle or editing too long and press Save (submit) button
3. got login screen with message:
"You have been idle for too long.
Please re-enter your Password." (!) this important
4. user login
5. saving process continues, but memo lost or cutted (like ~300 bytes instead 900 bytes or more)

my pages has structure:

=doAuth()
... inits, open....
if !empty(Request.form("bSave"))
**** Save button pressed
...validations...
m.note = Request.form("note")
replace note with m.note
Server.transfer("message.fwx", "saved")
endif
....
**** show page
....

I try to catch problem on local server and set timeout =1 min
but after time gone and I press Save
if auto relogin was on - all data saved
off - I receive login screen (BUT without message), login and all data saved again

have some ideas ?